Skip to main content
mySites.guru
CriticalPHP2Shell is fixed, but a researcher now claims six more unpatched PHP flaws. Nothing to do today, but PHP is not out of the woodsWhat to prepare

JEvents security vulnerabilities

mySites.guru tracks 2 vulnerabilities in JEvents (com_jevents), covering 2 CVEs. Every connected Joomla site is checked against them on each audit.

Is my site affected?

Your site is affected if it runs JEvents in any of these ranges:

  • from 3.6.83 up to and including 3.6.87
  • up to and including 3.6.82
Latest safe version
3.6.88 or later. No rule we check matches that release or any newer one.
What to do
Update JEvents to 3.6.88 or later from the vendor, then confirm the installed version on the Joomla administrator's Extensions: Manage screen.

Every JEvents vulnerability we track

Newest first. CVSS is the score published in each CVE record, where it has one; the severity column is the rating our check uses.

CVEAffected versionsFixed inSeverityAdded
CVE-2025-49467CVSS 9.3CVE-2015-7340up to and including 3.6.82update to 3.6.88Critical2025-01-01
CVE-2025-49467CVSS 9.3from 3.6.83 up to and including 3.6.87update to 3.6.88Unrated-

What we check for

CriticalCVE-2025-49467CVE-2015-73402025-01-01

JEvents (com_jevents) 1.0.0 to 3.6.82 - CVE-2025-49467 (CVSS 9.3) Unauthenticated SQL Injection

JEvents versions 1.0.0 through 3.6.82 are vulnerable to unauthenticated SQL injection via publicly accessible actions that list events by date ranges (CVE-2025-49467, CVSS 4.0 9.3 Critical). No login is required. Fixed in 3.6.88; the vendor also released 3.6.82.1 as a backport hotfix for the 3.6.82 line, which is NOT affected. Update to 3.6.88 or later (or 3.6.82.1 if staying on the older line). Also within this rule: CVE-2015-7340 (JEvents below 3.4.0), which sits below this ceiling and needs no separate row.

Affected versions: ≤ 3.6.82

Full advisory: ccb.belgium.be

JEvents (com_jevents) 3.6.83 to 3.6.87 - CVE-2025-49467 (CVSS 9.3) Unauthenticated SQL Injection

JEvents versions 3.6.83 through 3.6.87 are vulnerable to unauthenticated SQL injection via publicly accessible actions that list events by date ranges (CVE-2025-49467, CVSS 4.0 9.3 Critical). No login is required. These releases shipped without the fix that was backported to 3.6.82.1; the fix is in 3.6.88. Update to 3.6.88 or later.

Affected versions: ≥ 3.6.83 and ≤ 3.6.87

Full advisory: www.cve.org

Timeline

  1. 9 March 2020CVE-2015-7340 record published
  2. 1 January 2025Check added for CVE-2025-49467 and CVE-2015-7340 (up to and including 3.6.82)
  3. 12 June 2025CVE-2025-49467 record published

References

Each CVE page above links its official cve.org record and its NVD entry.

JEvents vulnerability questions

Which versions of JEvents are vulnerable?
mySites.guru tracks 2 vulnerabilities in JEvents (com_jevents). A site is affected if its installed version is in any of these ranges: from 3.6.83 up to and including 3.6.87; up to and including 3.6.82.
What is the latest safe version of JEvents?
3.6.88. Every vulnerability tracked here is fixed by 3.6.88, and no rule we check matches that release or any later one.
How do I check which version of JEvents my Joomla site runs?
The installed version is listed on the Joomla administrator's Extensions: Manage screen; search it for com_jevents. mySites.guru reads the installed version on every audit of a connected site and checks it against these rules.

Running JEvents on a site you manage?

A free audit tells you which of your Joomla and WordPress sites run an affected version, which are out of date, and which have not been backed up. No card required. If a site is already compromised, fix.mysites.guru is a single fixed fee per incident, usually resolved the same day.

This check is part of the mySites.guru Joomla vulnerability scanner, which reads every installed extension's version on each audit. Browse the rest of the Joomla vulnerability database.

CVE identifiers: CVE-2025-49467, CVE-2015-7340. Rules current as of 25 October 2026.