Skip to main content
mySites.guru
CriticalPHP2Shell is fixed, but a researcher now claims six more unpatched PHP flaws. Nothing to do today, but PHP is not out of the woodsWhat to prepare

JoomShopping security vulnerabilities

mySites.guru tracks 2 vulnerabilities in JoomShopping (com_jshopping), covering 2 CVEs. Every connected Joomla site is checked against them on each audit.

Is my site affected?

Your site is affected if it runs JoomShopping in any of these ranges:

  • from 3.5.0 up to and including 5.9.2
  • from 1.0.0 up to and including 1.4.3
Latest safe version
5.9.3 or later. No rule we check matches that release or any newer one.
What to do
Update JoomShopping to 5.9.3 or later from the vendor, then confirm the installed version on the Joomla administrator's Extensions: Manage screen.

Every JoomShopping vulnerability we track

Newest first. CVSS is the score published in each CVE record, where it has one; the severity column is the rating our check uses.

CVEAffected versionsFixed inSeverityAdded
CVE-2026-63264CVSS 5.3from 3.5.0 up to and including 5.9.2update to 5.9.3Medium2026-07-22
CVE-2025-22211CVSS 3.4from 1.0.0 up to and including 1.4.3after 1.4.3Low2025-02-25

What we check for

MediumCVE-2026-632642026-07-22

JoomShopping (com_jshopping) 3.5.0 to 5.9.2 - Unauthenticated Reflected XSS

JoomShopping up to and including 5.9.2 contains a reflected cross-site scripting vulnerability in the product frontend controller. An attacker who gets a logged-in user or administrator to follow a crafted link can execute script in that user session. Update to 5.9.3 or later. This rule starts at 3.5.0 so it does not match the OSMap and Xmap JoomShopping companion plugins, which report their own 2.0.x-3.2.1 versions under the same element; the oldest real JoomShopping install seen in the wild is 3.12.0.

Affected versions: ≥ 3.5.0 and ≤ 5.9.2

Full advisory: www.joomshopping.com

LowCVE-2025-222112025-02-25

JoomShopping (com_jshopping) 1.0.0 to 1.4.3 - Authenticated (Administrator) SQL Injection

JoomShopping versions 1.0.0 to 1.4.3 are affected by an SQL injection in the backend country management area (CVE-2025-22211). An authenticated administrator can execute arbitrary SQL through the 'ordering' parameter when saving a country, so exploitation requires an existing administrator account and the practical risk is low. Read the version range with care, because the CVE record contradicts itself. Its structured affected range, its own description and the finder's published write-up all give 1.0.0 to 1.4.3, which is the range this advisory uses, but the CVE's title instead says 'version 1.0.0 - 5.5.5'. Every JoomShopping install we can see runs between 3.12.0 and 5.9.4, so on the stated range this advisory matches no version currently in use and must NOT be read as clearing a site running 4.x or 5.x. Update to the current JoomShopping release.

Affected versions: ≥ 1.0.0 and ≤ 1.4.3

Full advisory: nvd.nist.gov

Timeline

  1. 25 February 2025Check added for CVE-2025-22211 (from 1.0.0 up to and including 1.4.3)
  2. 25 February 2025CVE-2025-22211 record published
  3. 22 July 2026Check added for CVE-2026-63264 (from 3.5.0 up to and including 5.9.2)
  4. 22 July 2026CVE-2026-63264 record published

References

Each CVE page above links its official cve.org record and its NVD entry.

JoomShopping vulnerability questions

Which versions of JoomShopping are vulnerable?
mySites.guru tracks 2 vulnerabilities in JoomShopping (com_jshopping). A site is affected if its installed version is in any of these ranges: from 3.5.0 up to and including 5.9.2; from 1.0.0 up to and including 1.4.3.
What is the latest safe version of JoomShopping?
5.9.3. Every vulnerability tracked here is fixed by 5.9.3, and no rule we check matches that release or any later one.
How do I check which version of JoomShopping my Joomla site runs?
The installed version is listed on the Joomla administrator's Extensions: Manage screen; search it for com_jshopping. mySites.guru reads the installed version on every audit of a connected site and checks it against these rules.

Running JoomShopping on a site you manage?

A free audit tells you which of your Joomla and WordPress sites run an affected version, which are out of date, and which have not been backed up. No card required. If a site is already compromised, fix.mysites.guru is a single fixed fee per incident, usually resolved the same day.

This check is part of the mySites.guru Joomla vulnerability scanner, which reads every installed extension's version on each audit. Browse the rest of the Joomla vulnerability database.

CVE identifiers: CVE-2026-63264, CVE-2025-22211. Rules current as of 25 October 2026.