Skip to main content
mySites.guru
CriticalPHP2Shell is fixed, but a researcher now claims six more unpatched PHP flaws. Nothing to do today, but PHP is not out of the woodsWhat to prepare
CVE-2025-25228LowCVSS 3.8CVE published 21 April 2025Added to mySites.guru 9 April 2026

VirtueMart (com_virtuemart) below 4.4.11 - Unauthenticated Reflected XSS and Authenticated SQL Injection

VirtueMart e-commerce component. CVE-2025-55757 (unauthenticated reflected XSS, affects 1.0.0-4.4.10) and CVE-2025-25228 (authenticated SQL injection in product management, affects 1.0.0-4.4.7). Fixed in 4.4.11. Rule pinned to component type because the Xmap and OSMap VirtueMart bridge plugins ship under element com_virtuemart at their own low versions. Also within this rule: CVE-2023-54362 (VirtueMart Cart 4.0.12 reflected XSS), which sits below this ceiling and needs no separate row.

Is my site affected?

Affected
VirtueMart before 4.4.11
Fixed in
4.4.11
What to do
Update VirtueMart to 4.4.11 or later.

How CVE-2025-25228 is scored

The base metrics as CISA-ADP published them, and what each one means for a site running an affected version. Threat and environmental metrics are left out: they describe a moment or a particular install rather than the flaw.

3.8 Low

CVSS 3.1, scored by CISA-ADP
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N

How it is reached

AV:N Attack vector
Network. Reachable across the internet
AC:L Attack complexity
Low. Nothing to work around, it just works
PR:H Privileges required
High. Needs an account with elevated rights
UI:N User interaction
None. Nobody has to be tricked into anything
S:U Scope
Unchanged. Contained to the extension it is in

What it does

C:L Confidentiality
Low. Some data can be read
I:L Integrity
Low. Some data can be altered
A:N Availability
None. The site stays up

The rule below is rated Medium for the set of 3 CVEs it covers together, not for this record on its own.

Timeline

  1. 21 April 2025CVE-2025-25228 record published by its CNA
  2. 9 April 2026mySites.guru check added for VirtueMart (before 4.4.11)

Rule details

Other vulnerabilities in VirtueMart

Updating for CVE-2025-25228 alone can leave a site on a release another rule still matches. These are the other flaws we check for in the same extension.

VirtueMart

Latest safe version: 4.4.11

References

CVE-2025-25228 questions

Which versions are affected by CVE-2025-25228?
CVE-2025-25228 affects VirtueMart before 4.4.11. The fix is in 4.4.11.
How do I fix CVE-2025-25228?
Update VirtueMart to 4.4.11 or later. Then confirm the installed version on the Joomla administrator's Extensions: Manage screen.
How severe is CVE-2025-25228?
CISA-ADP scores it 3.8 (Low) under CVSS 3.1. In plain terms: reachable across the internet, needs an account with elevated rights and nobody has to be tricked into anything.

Running an affected version on a site you manage?

A free audit tells you which of your Joomla and WordPress sites run an affected version, which are out of date, and which have not been backed up. No card required. If a site is already compromised, fix.mysites.guru is a single fixed fee per incident, usually resolved the same day.

This check is part of the mySites.guru Joomla vulnerability scanner, which reads every installed extension's version on each audit. Browse the rest of the Joomla vulnerability database.

Rules current as of 25 October 2026.