Skip to main content
mySites.guru
CriticalPHP2Shell is fixed, but a researcher now claims six more unpatched PHP flaws. Nothing to do today, but PHP is not out of the woodsWhat to prepare
CVE-2025-27753MediumCVSS 6.5CVE published 5 June 2025

RSMediaGallery! (com_rsmediagallery) 1.7.4 to below 2.1.8 - Authenticated SQL Injection

RSMediaGallery! by RSJoomla. CVE-2025-27753 and CVE-2025-32466: SQL injection via unescaped user-supplied parameters in the dashboard. Affects 1.7.4-2.1.7, fixed in 2.1.8.

Is my site affected?

Affected
RSMediaGallery! from 1.7.4 up to but not including 2.1.8
Fixed in
2.1.8
What to do
Update RSMediaGallery! to 2.1.8 or later.

How CVE-2025-27753 is scored

The base metrics as CISA-ADP published them, and what each one means for a site running an affected version. Threat and environmental metrics are left out: they describe a moment or a particular install rather than the flaw.

6.5 Medium

CVSS 3.1, scored by CISA-ADP
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

How it is reached

AV:N Attack vector
Network. Reachable across the internet
AC:L Attack complexity
Low. Nothing to work around, it just works
PR:N Privileges required
None. No account needed
UI:N User interaction
None. Nobody has to be tricked into anything
S:U Scope
Unchanged. Contained to the extension it is in

What it does

C:L Confidentiality
Low. Some data can be read
I:L Integrity
Low. Some data can be altered
A:N Availability
None. The site stays up

Timeline

  1. 5 June 2025CVE-2025-27753 record published by its CNA

Rule details

Other vulnerabilities in RSMediaGallery!

Updating for CVE-2025-27753 alone can leave a site on a release another rule still matches. These are the other flaws we check for in the same extension.

RSMediaGallery!

Latest safe version: 2.1.8

References

CVE-2025-27753 questions

Which versions are affected by CVE-2025-27753?
CVE-2025-27753 affects RSMediaGallery! from 1.7.4 up to but not including 2.1.8. The fix is in 2.1.8.
How do I fix CVE-2025-27753?
Update RSMediaGallery! to 2.1.8 or later. Then confirm the installed version on the Joomla administrator's Extensions: Manage screen.
How severe is CVE-2025-27753?
CISA-ADP scores it 6.5 (Medium) under CVSS 3.1. In plain terms: reachable across the internet, no account needed and nobody has to be tricked into anything.

Running an affected version on a site you manage?

A free audit tells you which of your Joomla and WordPress sites run an affected version, which are out of date, and which have not been backed up. No card required. If a site is already compromised, fix.mysites.guru is a single fixed fee per incident, usually resolved the same day.

This check is part of the mySites.guru Joomla vulnerability scanner, which reads every installed extension's version on each audit. Browse the rest of the Joomla vulnerability database.

Rules current as of 25 October 2026.