Skip to main content
mySites.guru
CriticalPHP2Shell is fixed, but a researcher now claims six more unpatched PHP flaws. Nothing to do today, but PHP is not out of the woodsWhat to prepare
CVE-2025-27754MediumCVSS 6.5CVE published 5 June 2025Added to mySites.guru 1 January 2025

RSBlog! (com_rsblog) 1.11.6 to 1.14.5 - CVE-2025-50126 Stored XSS

RSBlog! by RSJoomla! versions 1.11.6 to 1.14.5 contain a stored XSS vulnerability (CVE-2025-50126): an authenticated user can inject arbitrary HTML/JavaScript via the jform[tags_text] parameter, which is executed when other users view the affected content. Update RSBlog! to 1.14.6 or later. Also covered by this rule: CVE-2025-27754, a stored XSS in RSBlog! 1.11.6 to 1.14.4 that lets an authenticated user inject JavaScript which is executed when other users view the affected content.

Is my site affected?

Affected
RSBlog! from 1.11.6 up to but not including 1.14.6
Fixed in
1.14.6
What to do
Update RSBlog! to 1.14.6 or later.

How CVE-2025-27754 is scored

The base metrics as CISA-ADP published them, and what each one means for a site running an affected version. Threat and environmental metrics are left out: they describe a moment or a particular install rather than the flaw.

6.5 Medium

CVSS 3.1, scored by CISA-ADP
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:L

How it is reached

AV:N Attack vector
Network. Reachable across the internet
AC:H Attack complexity
High. The attacker has to defeat a mitigation first
PR:N Privileges required
None. No account needed
UI:N User interaction
None. Nobody has to be tricked into anything
S:C Scope
Changed. The flaw reaches past the extension it is in

What it does

C:L Confidentiality
Low. Some data can be read
I:L Integrity
Low. Some data can be altered
A:L Availability
Low. The site slows or stutters

Timeline

  1. 1 January 2025mySites.guru check added for RSBlog! (from 1.11.6 up to but not including 1.14.6)
  2. 5 June 2025CVE-2025-27754 record published by its CNA

Rule details

Other vulnerabilities in RSBlog!

Updating for CVE-2025-27754 alone can leave a site on a release another rule still matches. These are the other flaws we check for in the same extension.

RSBlog!

Latest safe version: 1.14.6

References

CVE-2025-27754 questions

Which versions are affected by CVE-2025-27754?
CVE-2025-27754 affects RSBlog! from 1.11.6 up to but not including 1.14.6. The fix is in 1.14.6.
How do I fix CVE-2025-27754?
Update RSBlog! to 1.14.6 or later. Then confirm the installed version on the Joomla administrator's Extensions: Manage screen.
How severe is CVE-2025-27754?
CISA-ADP scores it 6.5 (Medium) under CVSS 3.1. In plain terms: reachable across the internet, no account needed and nobody has to be tricked into anything.

Running an affected version on a site you manage?

A free audit tells you which of your Joomla and WordPress sites run an affected version, which are out of date, and which have not been backed up. No card required. If a site is already compromised, fix.mysites.guru is a single fixed fee per incident, usually resolved the same day.

This check is part of the mySites.guru Joomla vulnerability scanner, which reads every installed extension's version on each audit. Browse the rest of the Joomla vulnerability database.

Rules current as of 25 October 2026.